Look Here For The Latest Madass Army and Community News.

strange clicking noise

Topics and discussions about upgrading, modifying and/or repairing the MadAss.

Moderators: Greg, MilwaukeeMadass, MadMaster

strange clicking noise

Postby Whoobie » 14 Mar 2012 21:24

not too savvy with the madass just yet, completly stock and when i ride it it seems to have a clicking noise from a black cinlyndrical part on the left front side of the engine. It has done this since the day i got it. I believe it is normal i am just wanting to know if anyone else has noticed the same thing. When i look at photos and videos of other peoples modded madasses i never see this part on theirs. just curious

Whoobie
Member
 
Posts: 21
Joined: 11 Mar 2012 19:28
Liked Posts: 1 time
Posts Liked: 1 time

Re: strange clicking noise

Postby Whoobie » 15 Mar 2012 06:08

Edit: i found out it may be my emissions canister. And i have plans to uninstall it this weekend. Any advise before hand?:)

Whoobie
Member
 
Posts: 21
Joined: 11 Mar 2012 19:28
Liked Posts: 1 time
Posts Liked: 1 time

Re: strange clicking noise

Postby goplaycheckers » 04 Jun 2012 15:07

Check out my post here.
User avatar
goplaycheckers
Fanatic
 
Posts: 104
Joined: 16 Aug 2010 12:41
Location: St. Louis, Missouri
Liked Posts: 5 times
Posts Liked: 18 times

Re: strange clicking noise

Postby arsyan » 31 Aug 2012 15:19

hi whoobie,

i noticed when i first got my madass 125 yellow color, when i start to move, theres a CLICK CLICK CLICK CLICK CLICK sound everytime the tyres makes a rev. I checked on the front tyre there's nothing there im not sure whats making that clicking sound too on mine ...

If i push the motor slowly, theres no sound. But when i push it slightly fast (pushing meaning im on the ground pushing the bike engine off) the clicking sound starts to come. Im puzzled, anybody?

arsyan
Recruit
 
Posts: 2
Joined: 31 Aug 2012 08:48
Liked Posts: 0 time
Posts Liked: 0 time

Re: strange clicking noise

Postby syvil » 23 Feb 2015 23:09

In case anyone else is experiencing this issue. I had the same exact issue. In neutral there was a very nasty clicking noise and sometimes while in gear.

I removed the emissions canister following goplaycheckers' guide and all is well now. In my case there was a rubber piece that attached the engine that wore out causing the canister to knock against the engine.

I also noticed an increase in HP and throttle response since removing. I used vacuum caps on the hose connections and put zip ties on them.

syvil
Member
 
Posts: 24
Joined: 17 Jan 2015 18:29
Liked Posts: 0 time
Posts Liked: 0 time


Return to The Garage: MadAss Mods, Upgrades, and Repairs

Who is online

Users browsing this forum: No registered users and 1 guest

cron